<thead id="nfptn"><track id="nfptn"><meter id="nfptn"></meter></track></thead>

              <font id="nfptn"></font><menuitem id="nfptn"></menuitem>
              <font id="nfptn"></font><menuitem id="nfptn"></menuitem>
              <menuitem id="nfptn"></menuitem>
              <font id="nfptn"></font>

                  ?
                  學維修技術找交航,華東地區規模大技術權威的電子類培訓學校,開設培訓課程:臺式電腦、筆記本、打印機復印機、智能手機、家電、空調維修培訓等項目. 維修網站 維修論壇
                  您當前位置:主頁 > 信息中心 > 網絡 >

                  網絡

                  強烈推薦新手:路由器配置!

                  本文關鍵詞: 培訓 網絡 工程師 路由器

                  第一章:路由器配置基礎
                  一、基本設置方式
                  一般來說,可以用5種方式來設置路由器:
                  1.Console口接終端或運行終端仿真軟件的微機;
                  2.AUX口接MODEM,通過電話線與遠方的終端或運行終端仿真軟件的微機相連;
                  3.通過Ethernet上的TFTP服務器;
                  4.通過Ethernet上的TELNET程序;
                  5.通過Ethernet上的SNMP網管工作站。
                  但路由器的第一次設置必須通過第一種方式進行,此時終端的硬件設置如下:
                  波特率 :9600
                  數據位 :8
                  停止位 :1
                  奇偶校驗: 無
                  二、命令狀態
                  1. router>
                  路由器處于用戶命令狀態,這時用戶可以看路由器的連接狀態,訪問其它網絡和主機,但不能看到和更改路由器的設置內容。
                  2. router#
                  在router>提示符下鍵入enable,路由器進入特權命令狀態router#,這時不但可以執行所有的用戶命令,還可以看到和更改路由器的設置內容。
                  3. router(config)#
                  在router#提示符下鍵入configure terminal,出現提示符router(config)#,此時路由器處于全局設置狀態,這時可以設置路由器的全局參數。
                  4. router(config-if)#; router(config-line)#; router(config-router)#;…
                  路由器處于局部設置狀態,這時可以設置路由器某個局部的參數。
                  5. >
                  路由器處于RXBOOT狀態,在開機后60秒內按ctrl-break可進入此狀態,這時路由器不能完成正常的功能,只能進行軟件升級和手工引導。
                  設置對話狀態
                  這是一臺新路由器開機時自動進入的狀態,在特權命令狀態使用SETUP命令也可進入此狀態,這時可通過對話方式對路由器進行設置。
                  三、設置對話過程
                  顯示提示信息
                  全局參數的設置
                  接口參數的設置
                  顯示結果
                  利用設置對話過程可以避免手工輸入命令的煩瑣,但它還不能完全代替手工設置,一些特殊的設置還必須通過手工輸入的方式完成。
                  進入設置對話過程后,路由器首先會顯示一些提示信息:
                  --- System Configuration Dialog ---
                  At any point you may enter a question mark '?' for help.
                  Use ctrl-c to abort configuration dialog at any prompt.
                  Default settings are in square brackets '[]'.
                  這是告訴你在設置對話過程中的任何地方都可以鍵入“?”得到系統的幫助,按ctrl-c可以退出設置過程,缺省設置將顯示在‘[]’中。然后路由器會問是否進入設置對話:
                  Would you like to enter the initial configuration dialog? [yes]:
                  如果按y或回車,路由器就會進入設置對話過程。首先你可以看到各端口當前的狀況:
                  First, would you like to see the current interface summary? [yes]:
                  Any interface listed with OK? value "NO" does not have a valid configuration
                  Interface  IP-Address  OK?  Method  Status  Protocol
                  Ethernet0  unassigned  NO  unset  up  up
                  Serial0  unassigned  NO  unset  up  up
                  ………  ………  …  ……  …  …
                  然后,路由器就開始全局參數的設置:
                  Configuring global parameters:
                  1.設置路由器名:
                  Enter host name [Router]:
                  2.設置進入特權狀態的密文(secret),此密文在設置以后不會以明文方式顯示:
                  The enable secret is a one-way cryptographic secret used
                  instead of the enable password when it exists.
                  Enter enable secret: cisco
                  3.設置進入特權狀態的密碼(password),此密碼只在沒有密文時起作用,并且在設置以后會以明文方式顯示:
                  The enable password is used when there is no enable secret
                  and when using older software and some boot images.
                  Enter enable password: pass
                  4.設置虛擬終端訪問時的密碼:
                  Enter virtual terminal password: cisco
                  5.詢問是否要設置路由器支持的各種網絡協議:
                  Configure SNMP Network Management? [yes]:
                  Configure DECnet? [no]:
                  Configure AppleTalk? [no]:
                  Configure IPX? [no]:
                  Configure IP? [yes]:
                  Configure IGRP routing? [yes]:
                  Configure RIP routing? [no]:
                  ………
                  6.如果配置的是撥號訪問服務器,系統還會設置異步口的參數:
                  Configure Async lines? [yes]:
                  1) 設置線路的最高速度:
                  Async line speed [9600]:
                  2) 是否使用硬件流控:
                  Configure for HW flow control? [yes]:
                  3) 是否設置modem:
                  Configure for modems? [yes/no]: yes
                  4) 是否使用默認的modem命令:
                  Configure for default chat s cript? [yes]:
                  5) 是
                  2004-1-10 21:15 aqbhc
                  六、配置靜態路由
                  通過配置靜態路由,用戶可以人為地指定對某一網絡訪問時所要經過的路徑,在網絡結構比較簡單,且一般到達某一網絡所經過的路徑唯一的情況下采用靜態路由。
                  任務  命令
                  建立靜態路由  ip route prefix mask {address | interface} [distance] [tag tag] [permanent]
                  Prefix :所要到達的目的網絡
                  mask   :子網掩碼
                  address :下一個跳的IP地址,即相鄰路由器的端口地址。
                  interface  :本地網絡接口
                  distance :管理距離(可選)
                  tag tag :tag值(可選)
                  permanent :指定此路由即使該端口關掉也不被移掉。
                  以下在Router1上設置了訪問192.1.0.64/26這個網下一跳地址為192.200.10.6,即當有目的地址屬于 192.1.0.64/26的網絡范圍的數據報,應將其路由到地址為192.200.10.6的相鄰路由器。在Router3上設置了訪問 192.1.0.128/26及192.200.10.4/30這二個網下一跳地址為192.1.0.65。由于在Router1上端口Serial 0地址為192.200.10.5,192.200.10.4/30這個網屬于直連的網,已經存在訪問192.200.10.4/30的路徑,所以不需要 在Router1上添加靜態路由。
                  Router1:
                  ip route 192.1.0.64 255.255.255.192 192.200.10.6
                  Router3:
                  ip route 192.1.0.128 255.255.255.192 192.1.0.65
                  ip route 192.200.10.4 255.255.255.252 192.1.0.65
                  同時由于路由器Router3除了與路由器Router2相連外,不再與其他路由器相連,所以也可以為它賦予一條默認路由以代替以上的二條靜態路由,
                  ip route 0.0.0.0 0.0.0.0 192.1.0.65
                  即只要沒有在路由表里找到去特定目的地址的路徑,則數據均被路由到地址為192.1.0.65的相鄰路由器。
                  第二章:廣域網協議設置

                  一、HDLC
                   HDLC是CISCO路由器使用的缺省協議,一臺新路由器在未指定封裝協議時默認使用HDLC封裝。
                  1. 有關命令
                  端口設置
                  任務  命令
                  設置HDLC封裝  encapsulation hdlc
                  設置DCE端線路速度  clockrate speed
                  復位一個硬件接口  clear interface serial unit
                  顯示接口狀態  show interfaces serial [unit] 1
                  注:1.以下給出一個顯示Cisco同步串口狀態的例子.
                  Router#show interface serial 0
                  Serial 0 is up, line protocol is up
                  Hardware is MCI Serial
                  Internet address is 150.136.190.203, subnet mask is 255.255.255.0
                  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, rely 255/255, load 1/255
                  Encapsulation HDLC, loopback not set, keepalive set (10 sec)
                  Last input 0:00:07, output 0:00:00, output hang never
                  Output queue 0/40, 0 drops; input queue 0/75, 0 drops
                  Five minute input rate 0 bits/sec, 0 packets/sec
                  Five minute output rate 0 bits/sec, 0 packets/sec
                  16263 packets input, 1347238 bytes, 0 no buffer
                  Received 13983 broadcasts, 0 runts, 0 giants
                  2 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 2 abort
                  22146 packets output, 2383680 bytes, 0 underruns
                  0 output errors, 0 collisions, 2 interface resets, 0 restarts
                  1 carrier transitions
                  2. 舉例
                   
                   
                   
                  設置如下:
                  Router1:
                  interface Serial0
                  ip address 192.200.10.1 255.255.255.0
                  clockrate 1000000
                  Router2:
                  interface Serial0
                  ip address 192.200.10.2 255.255.255.0
                  !
                  3. 舉例使用E1線路實現多個64K專線連接.
                  相關命令:
                  任務  命令
                  進入controller配置模式  controller {t1 | e1} number
                  選擇幀類型   framing {crc4 | no-crc4}
                  選擇line-code類型   linecode {ami | b8zs | hdb3}
                  建立邏輯通道組與時隙的映射   channel-group number timeslots range1
                  顯示controllers接口狀態  show controllers e1 [slot/port]2
                  注: 1. 當鏈路為T1時,channel-group編號為0-23, Timeslot范圍1-24; 當鏈路為E1時, channel-group編號為0-30, Timeslot范圍1-31.
                  2.使用show controllers e1觀察controller狀態,以下為幀類型為crc4時controllers正常的狀態.
                  Router# show controllers e1
                  e1 0/0 is up.
                  Applique type is Channelized E1 - unbalanced
                  Framing is CRC4, Line Code is HDB3 No alarms detected.
                  Data in current interval (725 seconds elapsed):
                  0 Line Code Violations, 0 Path Code Violations
                  0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
                  0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
                  Total Data (last 24 hours) 0 Line Code Violations, 0 Path Code Violations,
                  0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,
                  0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
                  以下例子為E1連接3條64K專線, 幀類型為NO-CRC4,非平衡鏈路,路由器具體設置如下:
                  shanxi#wri t
                  Building configuration...
                  Current configuration:
                  !
                  version 11.2
                  no service udp-small-servers
                  no service tcp-small-se
                  2004-1-10 21:16 aqbhc
                  三、x.25
                  1. X25技術
                  X.25規范對應OSI三層,X.25的第 三層描述了分組的格式及分組交換的過程。X.25的第二層由LAPB(Link Access Procedure, Balanced)實現,它定義了用于DTE/DCE連接的幀格式。X.25的第一層定義了電氣和物理端口特性。
                  X.25網絡設備分為數據終端設 備(DTE)、數據電路終端設備(DCE)及分組交換設備(PSE)。DTE是X.25的末端系統,如終端、計算機或網絡主機,一般位于用戶端, Cisco路由器就是DTE設備。DCE設備是專用通信設備,如調制解調器和分組交換機。PSE是公共網絡的主干交換機。
                  X.25定義了數據通訊 的電話網絡,每個分配給用戶的x.25 端口都具有一個x.121地址,當用戶申請到的是SVC(交換虛電路)時,x.25一端的用戶在訪問另一端的用戶時,首先將呼叫對方x.121地址,然后 接收到呼叫的一端可以接受或拒絕,如果接受請求,于是連接建立實現數據傳輸,當沒有數據傳輸時掛斷連接,整個呼叫過程就類似我們撥打普通電話一樣,其不同 的是x.25可以實現一點對多點的連接。其中x.121地址、htc均必須與x.25服務提供商分配的參數相同。X.25 PVC(永久虛電路),沒有呼叫的過程,類似DDN專線。
                  2. 有關命令:
                  任務  命令
                  設置X.25封裝  encapsulation x25 [dce]
                  設置X.121地址  x25 address x.121-address
                  設置遠方站點的地址映射  x25 map protocol address [protocol2 address2[...[protocol9 address9]]] x121-address [option]
                  設置最大的雙向虛電路數  x25 htc citcuit-number1
                  設置一次連接可同時建立的虛電路數  x25 nvc count2
                  設置x25在清除空閑虛電路前的等待周期  x25 idle minutes
                  重新啟動x25,或清一個svc,啟動一個pvc相關參數  clear x25 {serial number | cmns-interface mac-address} [vc-number] 3
                  清x25虛電路  clear x25-vc
                  顯示接口及x25相關信息  show interfaces serial show x25 interface show x25 map show x25 vc
                  注:1、虛電路號從1到4095,Cisco路由器默認為1024,國內一般分配為16。
                  2、虛電路計數從1到8,缺省為1。
                  3、 在改變了x.25各層的相關參數后,應重新啟動x25(使用clear x25 {serial number | cmns-interface mac-address} [vc-number]或clear x25-vc命令),否則新設置的參數可能不能生效。同時應對照服務提供商對于x.25交換機端口的設置來配置路由器的相關參數,若出現參數不匹配則可能 會導致連接失敗或其它意外情況。
                  3. 實例:
                  3.1. 在以下實例中每二個路由器間均通過svc實現連接。

                  路由器設置如下:
                  Router1:
                  interface Serial0
                  encapsulation x25
                  ip address 192.200.10.1 255.255.255.0
                  x25 address 110101
                  x25 htc 16
                  x25 nvc 2
                  x25 map ip 192.200.10.2 110102 broadcast
                  x25 map ip 192.200.10.3 110103 broadcast
                  !
                  Router2:
                  interface Serial0
                  encapsulation x25
                  ip address 192.200.10.2 255.255.255.0
                  x25 address 110102
                  x25 htc 16
                  x25 nvc 2
                  x25 map ip 192.200.10.1 110101 broadcast
                  x25 map ip 192.200.10.3 110103 broadcast
                  !
                  Router:
                  interface Serial0
                  encapsulation x25
                  ip address 192.200.10.3 255.255.255.0
                  x25 address 110103
                  x25 htc 16
                  x25 nvc 2
                  x25 map ip 192.200.10.1 110101 broadcast
                  x25 map ip 192.200.10.2 110102 broadcast
                  !
                  相關調試命令:
                  clear x25-vc
                  show interfaces serial
                  show x25 map
                  show x25 route
                  show x25 vc
                  3.2. 在以下實例中路由器router1和router2均通過svc與router連接,但router1和router2不通過svc直接連接,此三個路由 器的串口運行RIP路由協議,使用了子接口的概念。由于使用子接口,router1和router2均學習到了訪問對方局域網的路徑,若不使用子接口, router1和router2將學不到到對方局域網的路由。
                  子接口(Subinterface)是一個物理接口上的多個虛接口,可以用于在同一個物理接口上連接多個網。我們知道為了避免路由循環,路由器支持split horizon法則,它只允許路由更新被分配到路由器的其它接口,而不會再分配路由更新回到此路由被接收的接口。
                  無 論如何,在廣域網環境使用基于連接的接口(象 X.25和Frame Relay),同一接口通過虛電路(vc)連接多臺遠端路由器時,從同一接口來的路由更新信息不可以再被發回到相同的接口,除非強制使用分開的物理接口連 接不同的路由器。Cisco提供子接口(subinterface)作為分開的接口對待。你可以將路由器邏輯地連接到相同物理接口的不同子接口, 這樣來自不同子接口的路由更新就可以被分配到其他子接口,同時又滿足split horizon法則。
                  Router1:
                  interface Serial0
                  encapsulation x25
                  ip address 192.200.10.1 255.255.255.0
                  x25 address 110101
                  x25 htc 16
                  x25 nvc 2
                  x25 map ip 192.200.10.3 110103 broadcast
                  !
                  router rip
                  network 192.200.10.0
                  !
                  Router2:
                  interface Serial0
                  encapsulation x25
                  ip address 192.200.11.2 255.255.255.0
                  x25 address 110102
                  x25 htc 16
                  x25
                  2004-1-10 21:16 aqbhc
                  四、Frame Relay
                  1. 幀中繼技術
                  幀中繼是一種高性能的WAN 協議,它運行在OSI參考模型的物理層和數據鏈路層。它是一種數據包交換技術,是X.25的簡化版本。它省略了X.25的一些強健功能,如提供窗口技術和 數據重發技術,而是依靠高層協議提供糾錯功能,這是因為幀中繼工作在更好的WAN設備上,這些設備較之X.25的WAN設備具有更可靠的連接服務和更高的 可靠性,它嚴格地對應于OSI參考模型的最低二層,而X.25還提供第三層的服務,所以,幀中繼比X.25具有更高的性能和更有效的傳輸效率。
                  幀中繼廣域網的設備分為數據終端設備(DTE)和數據電路終端設備(DCE),Cisco路由器作為 DTE設備。
                  幀 中繼技術提供面向連接的數據鏈路層的通信,在每對設備之間都存在一條定義好的通信鏈路,且該鏈路有一個鏈路識別碼。這種服務通過幀中繼虛電路實現,每個幀 中繼虛電路都以數據鏈路識別碼(DLCI)標識自己。DLCI的值一般由幀中繼服務提供商指定。幀中繼即支持PVC也支持SVC。
                  幀中繼本地管理接口(LMI)是對基本的幀中繼標準的擴展。它是路由器和幀中繼交換機之間信令標準,提供幀中繼管理機制。它提供了許多管理復雜互聯網絡的特性,其中包括全局尋址、虛電路狀態消息和多目發送等功能。
                  2. 有關命令:
                  端口設置
                  任務  命令
                  設置Frame Relay封裝  encapsulation frame-relay[ietf] 1
                  設置Frame Relay LMI類型  frame-relay lmi-type {ansi | cisco | q933a}2
                  設置子接口  interface interface-type interface-number.subinterface-number [multipoint|point-to-point]
                  映射協議地址與DLCI  frame-relay map protocol protocol-address dlci [broadcast]3
                  設置FR DLCI編號  frame-relay interface-dlci dlci [broadcast]
                  注:1.若使Cisco路由器與其它廠家路由設備相連,則使用Internet工程任務組(IETF)規定的幀中繼封裝格式。
                  2.從Cisco IOS版本11.2開始,軟件支持本地管理接口(LMI)“自動感覺”, “自動感覺”使接口能確定交換機支持的LMI類型,用戶可以不明確配置LMI接口類型。
                  3.broadcast選項允許在幀中繼網絡上傳輸路由廣播信息。

                  4. ISDN訪問首都在線263網實例:
                  本地局部網地址為10.0.0.0/24,屬于保留地址,通過NAT地址翻譯功能,局域網用戶可以通過ISDN上263網訪問Internet。263的ISDN電話號碼為2633,用戶為263,口令為263,所涉及的命令如下表:
                  任務  命令
                  指定接口通過PPP/IPCP地址協商獲得IP地址  ip address negotiated
                  指定內部和外部端口  ip nat {inside | outside}
                  使用ppp/pap作認證  ppp authentication pap callin
                  指定接口屬于撥號組1  dialer-group 1
                  定義撥號組1允許所有IP協議  dialer-list 1 protocol ip permit
                  設定撥號,號碼為2633  dialer string 2633
                  設定登錄263的用戶名和口令  ppp pap sent-username 263 password 263
                  設定默認路由  ip route 0.0.0.0 0.0.0.0 bri 0
                  設定符合訪問列表2的所有源地址被翻譯為bri 0所擁有的地址  ip nat inside source list 2 interface bri 0 overload
                  設定訪問列表2,允許所有協議  access-list 2 permit any
                  具體配置如下:
                  hostname Cisco2503
                  !
                  isdn switch-type basic-net3
                  !
                  ip subnet-zero
                  no ip domain-lookup
                  ip routing
                  !
                  interface Ethernet 0
                  ip address 10.0.0.1 255.255.255.0
                  ip nat inside
                  no shutdown
                  !
                  interface Serial 0
                  shutdown
                  no des cription
                  no ip address
                  !
                  interface Serial 1
                  shutdown
                  no des cription
                  no ip address
                  !
                  interface bri 0
                  ip address negotiated
                  ip nat outside
                  encapsulation ppp
                  ppp authentication pap callin
                  ppp multilink
                  dialer-group 1
                  dialer hold-queue 10
                  dialer string 2633
                  dialer idle-timeout 120
                  ppp pap sent-username 263 password 263
                  no cdp enable
                  no ip split-horizon
                  no shutdown
                  !
                  ip classless
                  !
                  ! Static Routes
                  !
                  ip route 0.0.0.0 0.0.0.0 bri 0
                  !
                  ! Access Control List 2
                  !
                  access-list 2 permit any
                  !
                  dialer-list 1 protocol ip permit
                  !
                  ! Dynamic NAT
                  !
                  ip nat inside source list 2 interface bri 0 overload
                  snmp-server community public ro
                  !
                  line console 0
                  exec-timeout 0 0
                  !
                  line vty 0 4
                  !
                  end
                  5. Cisco765M通過ISDN撥號上263
                  由于Cisco765的設置命令與我們常用的Cisco路由器的命令不同,所以以下列舉了通過Cisco765上263訪問Internet的具體命令行設置步驟。

                  >set system c765
                  c765> set multidestination on
                  c765> set switch net3
                  c765> set ppp multilink on
                  c765> cd lan
                  c765:LAN> set ip routing on
                  c765:LAN> set ip address 10.0.0.1
                  c765:LAN> set ip netmask 255.0.0.0
                  c765:LAN> set briding off
                  c765:LAN>cd
                  c765> set user remotenet
                  New user remotenet being created
                  c765:remotenet> set ip routing on
                  c765:remotenet> set bri
                  2004-1-10 21:16 aqbhc
                  1.2. Access Server通過Tacacs服務器實現安全認證:
                  使用一臺WINDOWS NT服務器作為Tacacs服務器,地址為10.111.4.2,運行Cisco2511隨機帶的Easy ACS 1.0軟件實現用戶認證功能.
                  相關設置:
                  任務  命令
                  激活AAA訪問控制  aaa new-model
                  用戶登錄時默認起用Tacacs+做AAA認證  aaa authentication login default tacacs+
                  列表名為no_tacacs使用ENABLE口令做認證  aaa authentication login no_tacacs enable
                  在運行PPP的串行線上采用Tacacs+做認證  aaa authentication ppp default tacacs+
                  由TACACS+服務器授權運行EXEC  aaa authorization exec tacacs+
                  由TACACS+服務器授權與網絡相關的服務請求。  aaa authorization network tacacs+
                  為EXEC會話運行記帳.進程開始和結束時發通告給TACACS+服務器。  aaa accounting exec start-stop tacacs+
                  為與網絡相關的服務需求運行記帳包括SLIP,PPP,PPP NCPs,ARAP等.在進程開始和結束時發通告給TACACS+服務器。  aaa accounting network start-stop tacacs+
                  指定Tacacs服務器地址  tacacs-server host 10.111.4.2
                  在Tacacs+服務器和訪問服務器設定共享的關鍵字,訪問服務器和Tacacs+服務器使用這個關鍵字去加密口令和響應信息。這里使用tac作為關鍵字。  tacacs-server key tac
                  訪問服務器設置如下:
                  hostname router
                  !
                  aaa new-model
                  aaa authentication login default tacacs+
                  aaa authentication login no_tacacs enable
                  aaa authentication ppp default tacacs+
                  aaa authorization exec tacacs+
                  aaa authorization network tacacs+
                  aaa accounting exec start-stop tacacs+
                  aaa accounting network start-stop tacacs+
                  enable secret 5 $1$kN4g$CvS4d2.rJzWntCnn/0hvE0
                  !
                  interface Ethernet0
                  ip address 10.111.4.20 255.255.255.0
                  !
                  interface Serial0
                  no ip address
                  shutdown
                  interface Serial1
                  no ip address
                  shutdown
                  !
                  interface Group-Async1
                  ip unnumbered Ethernet0
                  encapsulation ppp
                  async mode interactive
                  peer default ip address pool Cisco2511-Group-142
                  no cdp enable
                  group-range 1 16
                  !
                  ip local pool Cisco2511-Group-142 10.111.4.21 10.111.4.36
                  tacacs-server host 10.111.4.2
                  tacacs-server key tac
                  !
                  line con 0
                  exec-timeout 0 0
                  password cisco
                  login authentication no_tacacs
                  line 1 16
                  login authentication tacacs
                  modem InOut
                  modem autoconfigure type usr_courier
                  autocommand ppp
                  transport input all
                  stopbits 1
                  rxspeed 115200
                  txspeed 115200
                  flowcontrol hardware
                  line aux 0
                  transport input all
                  line vty 0 4
                  password cisco
                  !
                  end
                  2. DDR(dial-on-demand routing)實例
                  此 例通過Cisco 2500系列路由器的aux端口實現異步撥號DDR連接。Router1撥號連接到Router2。其中采用PPP/CHAP做安全認證,在 Router1中應建立一個用戶,以對端路由器主機名作為用戶名,即用戶名應為Router2。同時在Router2中應建立一個用戶,以對端路由器主機 名作為用戶名,即用戶名應為Router1。所建的這兩用戶的password必須相同。
                  相關命令如下:
                  任務  命令
                  設置路由器與modem的接口指令  chat-s cript s cript-name EXPECT SEND EXPECT SEND (etc.)
                  設置端口在掛斷前的等待時間  dialer idle-timeout seconds
                  設 置協議地址與電話號碼的映射  dialer map protocol next-hop-address [name hostname] [broadcast] [modem-s cript modem-regexp] [system-s cript system-regexp] [dial-string]
                  設置電話號碼  dialer string dial-string
                  指定在特定線路下路由器默認 使用的chat-s cript  s cript {dialer|reset} s cript-name
                  Router1:
                  hostname Router1
                  !
                  enable secret 5 $1$QKI7$wXjpFqC74vDAyKBUMallw/
                  !
                  username Router2 password cisco
                  chat-s cript cisco-default "" "AT" TIMEOUT 30 OK "ATDT /T" TIMEOUT 30 CONNECT /c
                  !
                  interface Ethernet0
                  ip address 10.0.0.1 255.255.255.0
                  !
                  interface Async1
                  ip address 192.200.10.1 255.255.255.0
                  encapsulation ppp
                  async default routing
                  async mode dedicated
                  dialer in-band
                  dialer idle-timeout 60
                  dialer map ip 192.200.10.2 name Router2 modem-s cript cisco-default 573
                  dialer-group 1
                  ppp authentication chap
                  !
                  ip route 10.0.1.0 255.255.255.0 192.200.10.2
                  dialer-list 1 protocol ip permit
                  !
                  line con 0
                  line aux 0
                  modem InOut
                  modem autoconfigure discovery
                  flowcontrol hardware 

                  Router2:
                  hostname Router2
                  !
                  enable secret 5 $1$F6EV$5U8puzNt2/o9g.t56PXHo.
                  !
                  username Router1 password cisco
                  !
                  interface Ethernet0
                  ip address 10.0.1.1 255.255.255.0
                  !
                  interface Async1
                  ip address 192.200.10.2 255.255.255.0
                  encapsulation ppp
                  async default routing
                  asyn
                  2004-1-10 21:17 aqbhc
                  五、IPX協議設置
                   
                  IPX協議與IP協議是兩種不同的網絡層協議,它們的路由協議也不一樣,IPX的路由協議不象IP的路由協議那樣豐富,所以設置起來比較簡單。但IPX協議在以太網上運行時必須指定封裝形式。
                  1. 有關命令
                  啟動IPX路由  ipx routing
                  設置IPX網絡及以太網封裝形式  ipx network network [encapsulation encapsulation-type]1
                  指定路由協議,默認為RIP  ipx router {eigrp autonomous-system-number | nlsp [tag] | rip}
                  注:1.network 范圍是1 到FFFFFFFD.
                  IPX封裝類型列表
                  接口類型  封裝類型  IPX幀類型
                  Ethernet  novell-ether (默認) arpa sap snap  Ethernet_802.3 Ethernet_II Ethernet_802.2 Ethernet_Snap
                  Token Ring  sap (默認) snap  Token-Ring Token-Ring_Snap
                  FDDI  snap (默認) sap novell-fddi  Fddi_Snap Fddi_802.2 Fddi_Raw
                  舉例:
                  在 此例中,WAN的IPX網絡為3a00,Router1所連接的局域網IPX網絡號為2a00,在此局域網有一臺Novell服務器,IPX網絡號也是 2a00, 路由器接口的IPX網絡號必須與在同一網絡的Novell服務器上設置的IPX網絡號相同。路由器通過監聽SAP來建立已知的服務及自己的網絡地址表,并 每60秒發送一次自己的SAP表。
                  Router1:
                  ipx routing
                  interface ethernet 0
                  ipx network 2a00 encapsulation sap
                  !
                  interface serial 0
                  ipx network 3a00
                  !
                  ipx router eigrp 10
                  network 3a00
                  network 2a00

                  Router2:
                  ipx routing
                  interface ethernet 0
                  ipx network 2b00 encapsulation sap
                  !
                  interface serial 0
                  ipx network 3a00
                  !
                  ipx router eigrp 10
                  network 2b00
                  network 3a00
                  !
                  相關調試命令:
                  debug ipx packet
                  debug ipx routing
                  debug ipx sap
                  debug ipx spoof
                  debug ipx spx
                  show ipx eigrp interfaces
                  show ipx eigrp neighbors
                  show ipx eigrp topology
                  show ipx interface
                  show ipx route
                  show ipx servers
                  show ipx spx-spoof
                  第四章 服務質量及訪問控制
                  一、協議優先級設置
                   
                  1.有關命令
                  任務  命令
                  設置優先級表項目  priority-list list-number protocol protocol {high | medium | normal | low} queue-keyword keyword-value
                  使用指定的優先級表  priority-group list-number
                  2.舉例
                  Router1:
                  priority-list 1 protocol ip high tcp telnet
                  priority-list 1 protocol ip low tcp ftp
                  priority-list 1 default normal
                  interface serial 0
                  priority-group 1
                  二、隊列定制
                   
                  1.有關命令
                  任務  命令
                  設置隊列表中包含協議  queue-list list-number protocol protocol-name queue-number queue-keyword keyword-value
                  設置隊列表中隊列的大小  queue-list list-number queue queue-number byte-count byte-count-number
                  使用指定的隊列表  custom-queue-list list
                  2.舉例
                  Router1:
                  queue-list 1 protocol ip 0 tcp telnet
                  queue-list 1 protocol ip 1 tcp www
                  queue-list 1 protocol ip 2 tcp ftp
                  queue-list 1 queue 0 byte-count 300
                  queue-list 1 queue 1 byte-count 200
                  queue-list 1 queue 2 byte-count 100
                  interface serial 0
                  custom-queue-list 1
                  三、訪問控制
                   
                  1.有關命令
                  任務  命令
                  設置訪問表項目  access-list list {permit | deny} address mask
                  設置隊列表中隊列的大小  queue-list list-number queue queue-number byte-count byte-count-number
                  使用指定的訪問表  ip access-group list {in | out}
                  2.舉例
                  Router1:
                  access-list 1 deny 192.1.3.0 0.0.0.255
                  access-list 1 permit any
                  interface serial 0
                  ip access-group 1 in
                  第五章 虛擬局域網(VLAN)路由
                  一、虛擬局域網(VLAN)
                  當前在我們 構造企業網絡時所采用的主干網絡技術一般都是基于交換和虛擬網絡的。交換技術將共享介質改為獨占介質,大大提高網絡速度。虛擬網絡技術打破了地理環境的制 約,在不改動網絡物理連接的情況下可以任意將工作站在工作組或子網之間移動,工作站組成邏輯工作組或虛擬子網,提高信息系統的運作性能,均衡網絡數據流 量,合理利用硬件及信息資源。同時,利用虛擬網絡技術,大大減輕了網絡管理和維護工作的負擔,降低網絡維護費用。隨著虛擬網絡技術的應用,隨之必然產生了 在虛擬網間如何通訊的問題.
                  二、交換機間鏈路(ISL)協議
                    ISL(Interior Switching Link)協議用于實現交換機間的VLAN中繼。它是一個信息包標記協議,在支持ISL接口上發送的幀由一個標準以太網幀及相關的VLAN信息組成。如下圖所示,在支持ISL的接口上可以傳送來自不同VLAN的數據。
                  三、虛擬局域網(VLAN)路由實例
                   
                  3.1. 例一:
                   
                  設備選用Catalyst5500交換機1臺,安裝WS-X5530-E3管理引擎,多塊WS-X5225R及WS-X5302路由交換模塊, WS- X5302被直接插入交換機,通過二個通道與系統背板上的VLAN 相連,從用戶角度看認為它是1個1接口的模塊,此接口支持ISL。在交換
                  2004-1-10 21:22 aqbhc
                  Cisco 路由配置語句匯總
                  Cisco 路由配置語句匯總
                  啟動接口,分配IP地址:
                  router>
                  router> enable
                  router#
                  router# configure terminal
                  router(config)#
                  router(config)# interface Type Port
                  router(config-if)# no shutdown
                  router(config-if)# ip address IP-Address Subnet-Mask
                  router(config-if)# ^z
                  配置RIP路由協議:30秒更新一次
                  router(config)# router rip
                  router(config-if)# network Network-Number <--通告標準A,B,C類網-->
                  router(config-if)# ^z
                  配置IGRP路由協議:90秒更新一次
                  router(config)# router igrp AS-Number <-- AS-Number范圍1~65535-->
                  router(config-if)# network Network-Number <--通告標準A,B,C類網-->
                  router(config-if)# ^z
                  配置Novell IPX路由協議:Novell RIP 60秒更新一次
                  router(config)# ipx routing [node address]
                  router(config)# ipx maximum-paths Paths <--設置負載平衡,范圍1~512-->
                  router(config)# interface Type Port
                  router(config-if)# ipx network Network-Number [encapsulation encapsulation-type] [secondary] <--通告標準A,B,C類網-->
                  router(config-if)# ^z
                  配置DDR:
                  router(config)# dialer-list Group-Number protocol Protocol-Type permit [list ACL-Number]
                  router(config)# interface bri 0
                  router(config-if)# dialer-group Group-Number
                  router(config-if)# dialer map Protocol-Type Next-Hop-Address name Hostname Telphone-Number
                  router(config-if)# ^z
                  配置ISDN:
                  router(config)# isdn swith-type Swith-Type <--配置ISDN交換機類型,中國使用basic-net3-->
                  router(config-if)# ^z

                  __________________
                  配置Frame Relay:
                  router(config-if)# encapsulation frame-relay [cisco | ietf ]
                  router(config-if)# frame-relay lmi-type [ansi | cisco | q933a ]
                  router(config-if)# bandwidth kilobits
                  router(config-if)# frame-relay invers-arp [ Protocol ] [dlci ]
                  <--配置靜態Invers ARP表:
                  router(config)# frame-relay Protocol Protocol-Address DLCI [ Broadcast ] [ ietf | cisco ] [ payload-compress | packet-by-packet ]
                  -->
                  <--設置Keepalive間隔:
                  router(config-if)# keepalive Number
                  -->
                  <--為本地接口指定DLCI:
                  router(config-if)# frame-lelay local-dlci Number
                  -->
                  <--子接口配置:
                  router(config-if)# interface Type Port.Subininterface-Number [ multipoint | point-to-point ]
                  router(config-subif)# ip unnumbered Interface
                  router(config-subif)# frame-lelay local-dlci Number
                  -->
                  router(config-if)# ^z
                  配置標準ACL:
                  router(config)# access-list Access-List-Number [ permit | deny ] source [ source-mask ] <-- Access-List-Number 范圍:1~99標準ACL;100~199擴展ACL;800~899標準IPX ACL;900~999擴展IPX ACL;1000~1099 IPX SAP ACL;600~699Apple Talk ACL-->
                  router(config)# interface Type Port
                  router(config-if)# ip access-group Access-List-Number [ in | out ]
                  router(config-if)# ^z
                  配置擴展ACL:
                  router(config)# access-list Access-List-Number [ permit | deny ] [ Protocol | Protocol-Number ] source source-wildcard [ Source-Port ] destination destination-wildcard [ Destination-Port ] [ established ]
                  router(config)# interface Type Port
                  router(config-if)# ip access-group Access-List-Number [ in | out ]
                  router(config-if)# ^z
                  配置命名ACL:
                  router(config)# ip access-list [ standard | extended ] ACL-Name
                  router(config [ std- | ext- ] nacl)# [ permit | deny ] [ IP-Access-List-Test-Conditions ]
                  router(config [ std- | ext- ] nacl)# no [ permit | deny ] [ IP-Access-List-Test-Conditions ]
                  router(config [ std- | ext- ] nacl)# ^z
                  router(config)# interface Type Port
                  router(config-if)# ip access-group [ACL-Name | 1~199 ] [ in | out ]
                  router(config-if)# ^z
                  配置DCE時鐘:
                  router# show controllers Type Port <--確定DCE接口-->
                  router(confin-if)# clock rate 64000 <--進入DCE接口設置時鐘速率-->
                  router(config-if)# ^z
                  配置PPP協議:
                  router(config)# username Name password Set-Password-Here <--驗證方建立數據庫-->
                  router(config)# interface Type Port
                  router(config-if)# encapsulation ppp <--啟動PPP協議-->
                  router(config-if)# ppp outhentication [ chap | chap pap | pap chap | pap ] <--選擇PPP認證-->
                  router(config-if)# ppp pap sent-username Name password Password <--發送驗證信息-->
                  router(config-if)# ^z
                  PAP單向認證配置實例:
                  驗證方:
                  router-
                  2004-1-10 21:23 aqbhc
                  CHAP雙向認證配置實例:
                  路由器 A:
                  routerA(config)# username routerB password 12345
                  routerA(config)# interface serial 0
                  routerA(config-if)# encapsulation ppp
                  routerA(config-if)# ppp authentication chap
                  routerA(config-if)# ppp chap hostname routerA
                  routerA(config-if)# ppp chap password 54321
                  routerA(config-if)# ^z
                  路由器 B:
                  routerB(config)# username routerA password 54321
                  routerB(config)# interface serial 1
                  routerB(config-if)# encapsulation ppp
                  routerB(config-if)# ppp authentication chap
                  routerB(config-if)# ppp chap hostname routerB
                  routerB(config-if)# ppp chap password 12345
                  routerB(config-if)# ^z
                  Telnet使用:
                  routerA# terminal monitor <--可以傳回在遠端主機執行Debug命令的結果-->
                  routerA# telnet IP-Address [ Router-Name ] <--Telnet到指定的地址或名字的主機-->
                  routerB# [ exit | logout ] <--退出Telnet-->
                  routerB# ++<6>再按 <--掛起Telnet-->
                  routerA# show sessions <--顯示當前所有Telnet的信息,包括Connect-Number -->
                  routerA# Connect-Number <--返回指定的Telnet連接-->
                  routerA# disconnect IP-Address [ Router-Name ] <--斷開指定地址或名字的主機的連接-->
                  routerA# show user <--顯示Telnet到本機的連接信息-->
                  routerA# clear line [ 0 | 1 | 2 | 3 | 4 ] <--斷開指定Telnet到本機的連接-->
                  禁止任何Telnet到本機:
                  router(config)# line vty 0 4
                  router(config-line)# access-class ACL-Number
                  router(config)# ^z
                  設置主機名:
                  router(config)# hostname Set-Hostname
                  router(config)# ^z
                  router(config)# ^z
                  設置用戶模式密碼:
                  router(config)# line console 0
                  router(config-line)# login
                  router(config-line)# password Set-Password
                  router(config-line)# ^z
                  設置Telnet密碼:
                  router(config)# line vty 0 4
                  router(config-line)# login
                  router(config-line)# password Set-Password
                  router(config-line)# ^z
                  設置特權模式密碼:
                  router(config)# enable password Set-Password <--不加密的密碼,明碼-->
                  router(config)# enable secret Set-Password <--經過加密的密碼-->
                  router(config)# ^z
                  給所有密碼加密:
                  router(config)# service password-ancryption Set-Password-Here
                  router(config)# no service password-ancryption <--取消加密-->
                  router(config)# ^z
                  設置登錄Banner:
                  router(config)# banner motd 分隔符 Set-Banner-Information-Here 分隔符 <--前后分隔符一定要一致-->
                  設置接口的描述信息:
                  router(config-if)# description Set-Port-Information-Here
                  router(config)# ^z
                  CDP的控制:
                  router(config-if)# cdp enable <--在指定端口啟用CDP,缺省-->
                  router(config-if)# no cdp enable <--在指定端口關閉CDP-->
                  router(config)# cdp run <--使所有端口啟用CDP-->
                  router(config)# no cdp run <--使所有端口關閉CDP-->

                  __________________
                  Ping的使用:
                  router# ping IP-Address
                  router# ping <--擴展Ping命令-->
                  Protocol [ip]:[ Protocol-Type ] <--選擇協議類型-->
                  Target IP address:IP-Address <--輸入測試地址-->
                  Repeat count [5]: <--選擇發送的ICMP包數量-->
                  Datagram size [100]: <--選擇每個包的大小-->
                  Timeout in seconds [2]: <--設置每個包的超時時間-->
                  Extended commands [n]:y <--使用擴展Ping命令-->
                  Sweep range of sizes [n]:
                  Tracke的使用:
                  router# trace IP-Address [ Host-Name ]
                  為Cisco 4000路由器指定媒體類型:
                  router(config-if)# media-type 10baset <--使AUI(默認)失效,改為使用RJ-45-->
                  router(config-if)# ^z
                  更改路由器啟動順序:
                  router(config)# boot system flash IOS-FileName
                  router(config)# boot system tftp IOS-FileName TFTP-IP-Address
                  router(config)# boot system rom
                  router(config)# ^z
                  修改寄存器數值:
                  router(config)# config-register value <--Cisco出廠默認value=0x2102,value范圍:0x2100(進入ROM監視器),0x2101(使系統從ROM啟動), 0x2102~0x210F(使系統從NVRAM啟動)。0x1=0x2101,從最小位開始改變-->
                  在ROM監視器中更改寄存器數值:
                  > o/r value
                  路由器密碼的恢復:
                  冷關機,然后再開機并在60秒內按< Ctrl>+進入ROM監視器模式
                  > o/r 0x2142 <--25xx型路由器--> 或 > confreg 0x2142 <--16xx型路由器-->
                  router> I
                  router> n
                  router> enable
                  router# copy startup-config running-config
                  router# configure terminal
                  router(config)# enable secret New-Password
                  router(config)# config-register 0x2102
                  router(config)# ^z
                  router# copy running-
                  2004-1-10 21:40 aqbhc
                  Cisco VPN連接配置實例

                  在公司的南京辦事處與上海辦事處之間建立VPN聯接。
                  南京辦事處網絡設置:
                  內網IP 10.1.1.0/24
                  外網IP 202.102.1.5/24
                  上海辦事處網絡設置:
                  內網IP 10.1.2.0/24
                  外網IP 202.102.1.6/24

                  南京路由器配置
                  !
                  service timestamps debug uptime
                  service timestamps log uptime
                  no service password-encryption
                  !
                  hostname nanjing
                  !
                  enable cisco
                  !
                  !
                  !------以下配置加密--------
                  crypto isakmp policy 1 生成iskamp policy number 1
                  encryption des 選擇用DES encryption也可用3DES指定三倍DES加密
                  hash sha 指定使用的散列算法,也可以是md5(二端保持一致)
                  authentication pre-share
                  group 1 指定為Diffie-Hellman組,1表示768位,2表示1024位
                  lifetime 14400 指定安全關聯的有效期,不設就為默認值
                  ------以下配置密鑰方法-----
                  crypto isakmp identity address 指定與遠程路由器通信時使用isakmp標識
                  crypto isakmp key 654321 address 202.102.1.6 對遠程路由器端口202.102.1.6使用密鑰654321
                  crypto isakmp key 654321 address 192.168.1.2 對遠程路由器隧道端口192.168.1.2使用密鑰654321
                  !
                  ------以下定義一個轉換集-----
                  crypto ipsec transform-set tset1 ah-md5-hmac esp-des esp-md5-hmac 可以定義一個或多個集
                  !
                  !
                  -------以下建立加密圖------
                  crypto map cmap1 local-address serial 0 定義加密圖cmap1并指定s0為本地地址
                  crypto map cmap1 1 ipsec-isakmp 用序號1設置加密圖
                  set peer 202.102.1.6 設定目標地址
                  set peer 192.168.1.2
                  set transform-set test1 指定轉換集
                  match address 111 指定加密訪問列表111中的地址
                  !
                  !
                  process-max-time 200
                  !
                  -------以下設置隧道端口------
                  interface Tunnel0
                  ip address 192.168.1.1 255.255.255.0
                  tunnel source 202.102.1.5
                  tunnel destination 202.102.1.6
                  crypto map cmap
                  !
                  -------以下設置內網口------
                  interface Ethernet0
                  ip address 10.1.1.1 255.255.255.0
                  !
                  -------以下設置外網口------
                  interface serial0
                  ip address 202.102.1.5 255.255.255.0
                  no ip mroute-cache
                  no fair-queue
                  crypto map cmap
                  !
                  ip classless
                  !
                  -------以下建立訪問列表111------
                  access-list 111 permit ip host 202.102.1.5 host 202.102.1.6
                  access-list 111 permit ip host 202.102.1.6 host 202.102.1.5
                  access-list 111 permit ip 10.1.1.0 0.0.0.255 202.102.1.0 0.0.0.255
                  access-list 111 permit ip 10.1.2.0 0.0.0.255 202.102.1.0 0.0.0.255
                  access-list 111 permit ip 10.1.1.0 0.0.0.255 10.1.2.0 0.0.0.255
                  access-list 111 permit ip 10.1.2.0 0.0.0.255 10.1.1.0 0.0.0.255
                  !
                  line con 0
                  line aux 0
                  line vty 0 4
                  password cisco
                  login
                  !
                  end
                  !
                  上海路由器配置
                  !
                  service timestamps debug uptime
                  service timestamps log uptime
                  no service password-encryption
                  !
                  hostname shanghai
                  !
                  enable cisco
                  !
                  !
                  !------以下配置加密--------
                  crypto isakmp policy 1 生成iskamp policy number 1
                  encryption des 選擇用DES encryption也可用3DES指定三倍DES加密
                  hash sha 指定使用的散列算法,也可以是md5(二端保持一致)
                  authentication pre-share
                  group 1 指定為Diffie-Hellman組,1表示768位,2表示1024位
                  lifetime 14400 指定安全關聯的有效期,不設就為默認值
                  ------以下配置密鑰方法-----
                  crypto isakmp identity address 指定與遠程路由器通信時使用isakmp標識
                  crypto isakmp key 654321 address 202.102.1.5 對遠程路由器端口202.102.1.6使用密鑰654321
                  crypto isakmp key 654321 address 202.102.1.6 對遠程路由器端口202.102.1.6使用密鑰654321
                  crypto isakmp key 654321 address 192.168.1.1 對遠程路由器隧道端口192.168.1.2使用密鑰654321
                  !
                  ------以下定義一個轉換集-----
                  crypto ipsec transform-set tset1 ah-md5-hmac esp-des esp-md5-hmac 可以定義一個或多個集
                  !
                  !
                  -------以下建立加密圖------
                  crypto map cmap1 local-address serial 0 定義加密圖cmap1并指定s0為本地地址
                  crypto map cmap1 1 ipsec-isakmp 用序號1設置加密圖
                  set peer 202.102.1.5 設定目標地址
                  set peer 202.102.1.6
                  set peer 192.168.1.1
                  set transform-set test1 指定轉換集
                  match address 111 指定加密訪問列表111中的地址
                  !
                  !
                  process-max-time 200
                  !
                  -------以下設置隧道端口------
                  interface Tunnel0
                  ip address 192.168.1.2 255.255.255.0
                  tunnel source 202.102.1.6
                  tunnel destination 202.102.1.5
                  crypto map cmap
                  !
                  -------以下設置內網口------
                  interface Ethernet0
                  ip address 10.1.2.1 255.255.255.0
                  !
                  -------以下設置外網口------
                  interface serial0
                  ip address 202.102.1.6 255.255.255.0
                  no ip mroute-cache
                  no fair-queue
                  crypto map cmap
                  !
                  ip classless
                  !
                  ----
                  2004-1-10 21:42 aqbhc
                  vlan 配置思路
                  在交換機上創建vlan
                  1.建立一個vtp管理域
                  ×為了在交換機上創建vlan,必須首先建立一個vtp管理域以使它能夠核驗網絡
                  上當前的vlan
                  ×Catalyst 4000 系列交換機模塊只支持802.1q。
                  ×判斷硬件是否支持干道,及硬件所支持的干道封裝使用:show port
                  capabilities
                  首先運行 clear config all
                  vtp command:
                  在基于IOS的交換機上配置VTP管理域或加入一個管理域:
                  switch# vlan database
                  switch(vlan)# vtp domain domain-name
                  在基于CLI的交換機上配置VTP管理域:
                  switch(enable) set vtp [domain domain-name] passwd password
                  在基于IOS的交換機上配置VTP 模式:
                  switch# vlan database
                  switch(vlan)# vtp domain domain-name
                  switch(vlan)# vtp {sever|cilent|transparent}
                  switch(vlan)# vtp password password
                  在基于CLI的交換機上配置VTP 模式:
                  switch(enable) set vtp [domain domain-name] [mode{
                  sever|cilent|transparent }][password password]
                   
                  核驗vtp的配置:
                  show vtp domain
                  show vtp statistics

                  在基于IOS的交換機上配置VTP版本:
                  ×VTP版本1是缺省配置
                  switch# vlan database
                  switch(vlan)# vtp v2-mode
                  在基于CLI的交換機上配置VTP版本:
                  switch(enable) set vtp v2 enable
                  在基于IOS的交換機上啟動VTP剪裁:
                  switch# vlan database
                  switch(vlan)# vtp pruning
                  在基于CLI 的交換機上啟動VTP剪裁:
                  switch(enable) set vtp pruning enable
                  (set vtp pruneeligible vlan-range)
                  不起用vtp修剪:
                  clear vtp pruneeligible vlan-range
                   
                  核驗vtp修剪的配置:
                  show trunk

                  2.創建Vlan
                  在基于IOS的交換機上配置靜態VLAN:
                  switch# vlan database
                  switch(vlan)# vlan vlan-num name vlan-name
                  switch(vlan)# exit
                  switch# configure teriminal
                  switch(config)# interface interface module/number
                  switch(config-if)# switchport mode access
                  switch(config-if)# switchport access vlan vlan-num
                  switch(config-if)# end
                  在基于CLI的交換機上配置靜態VLAN:
                  switch(enable) set vlan vlan-num [name name]
                  switch(enable) set vlan vlan-num mod-num/port-list
                  核驗配置:show vlan

                  3.配置干道鏈路
                  干道是在兩臺catalyst交換機端口或catalyst交換機與路由器間的一條點對點
                  鏈路。
                  干道鏈路可以承載多個vlan。

                  在基于IOS的交換機上配置干道鏈路
                  switch(config)# interface interface mod/port
                  switch(config-if)# switchport mode trunk
                  switch(config-if)# switchport trunk encapsulation {isl|dotlq}
                  switch(config-if)# switchport trunk allowed vlan remove vlan-list
                  switch(config-if)# switchport trunk allowed vlan add vlan-list
                  在基于CLI的交換機上配置干道鏈路:
                  switch(enable) set trunk module/port
                  [on|off|desirable|auto|nonegotiate]
                  Vlan-range
                  [isl|dotlq|dotl0|lane|negotiate]

                  2004-1-10 21:43 aqbhc
                  如何配置Cisco PIX防火墻 (轉載自無限矩陣 作者:verve)
                  任何企業安全策略的一個主要部分都是實現和維護防火墻,因此防火墻在網絡安全的實現當中扮演著重要的角色。防火墻通常位于企業網絡的邊緣,這使 得內部網絡與Internet之間或者與其他外部網絡互相隔離,并限制網絡互訪從而保護企業內部網絡。設置防火墻目的都是為了在內部網與外部網之間設立唯 一的通道,簡化網絡的安全管理。
                  在眾多的企業級主流防火墻中,Cisco PIX防火墻是所有同類產品性能最好的一種。Cisco PIX系列防火墻目前有5種型號PIX506,515,520,525,535。其中PIX535是PIX 500系列中最新,功能也是最強大的一款。它可以提供運營商級別的處理能力,適用于大型的ISP等服務提供商。但是PIX特有的OS操作系統,使得大多數 管理是通過命令行來實現的,不象其他同類的防火墻通過Web管理界面來進行網絡管理,這樣會給初學者帶來不便。本文將通過實例介紹如何配置Cisco PIX防火墻。
                  在配置PIX防火墻之前,先來介紹一下防火墻的物理特性。防火墻通常具有至少3個接口,但許多早期的防火墻只具有2個接口;當使用具有3個接口的防火墻時,就至少產生了3個網絡,描述如下:
                  &Oslash; 內部區域(內網)。 內部區域通常就是指企業內部網絡或者是企業內部網絡的一部分。它是互連網絡的信任區域,即受到了防火墻的保護。
                  &Oslash; 外部區域(外網)。 外部區域通常指Internet或者非企業內部網絡。它是互連網絡中不被信任的區域,當外部區域想要訪問內部區域的主機和服務,通過防火墻,就可以實現有限制的訪問。
                  &Oslash; ?;饏^(DMZ)。?;饏^是一個隔離的網絡,或幾個網絡。位于?;饏^中的主機或服務器被稱為堡壘主機。一般在?;饏^內可以放置Web服務器,Mail服務 器等。?;饏^對于外部用戶通常是可以訪問的,這種方式讓外部用戶可以訪問企業的公開信息,但卻不允許他們訪問企業內部網絡。注意:2個接口的防火墻是沒有 ?;饏^的。
                  由于PIX535在企業級別不具有普遍性,因此下面主要說明PIX525在企業網絡中的應用。
                  PIX防火墻提供4種管理訪問模式:
                  &sup2; 非特權模式。 PIX防火墻開機自檢后,就是處于這種模式。系統顯示為pixfirewall>
                  &sup2; 特權模式。 輸入enable進入特權模式,可以改變當前配置。顯示為pixfirewall#
                  &sup2; 配置模式。 輸入configure terminal進入此模式,絕大部分的系統配置都在這里進行。顯示為pixfirewall(config)#
                  &sup2; 監視模式。 PIX防火墻在開機或重啟過程中,按住Escape鍵或發送一個“Break”字符,進入監視模式。這里可以更新操作系統映象和口令恢復。顯示為monitor>
                  配置PIX防火墻有6個基本命令:nameif,interface,ip address,nat,global,route.
                  這些命令在配置PIX是必須的。以下是配置的基本步驟:
                  1. 配置防火墻接口的名字,并指定安全級別(nameif)。
                  Pix525(config)#nameif ethernet0 outside security0
                  Pix525(config)#nameif ethernet1 inside security100
                  Pix525(config)#nameif dmz security50
                  提示:在缺省配置中,以太網0被命名為外部接口(outside),安全級別是0;以太網1被命名為內部接口(inside),安全級別是100.安全級別取值范圍為1~99,數字越大安全級別越高。若添加新的接口,語句可以這樣寫:
                  Pix525(config)#nameif pix/intf3 security40 (安全級別任?。?br /> 2. 配置以太口參數(interface)
                  Pix525(config)#interface ethernet0 auto(auto選項表明系統自適應網卡類型 )
                  Pix525(config)#interface ethernet1 100full(100full選項表示100Mbit/s以太網全雙工通信 )
                  Pix525(config)#interface ethernet1 100full shutdown (shutdown選項表示關閉這個接口,若啟用接口去掉shutdown )
                  3. 配置內外網卡的IP地址(ip address)
                  Pix525(config)#ip address outside 61.144.51.42 255.255.255.248
                  Pix525(config)#ip address inside 192.168.0.1 255.255.255.0
                  很明顯,Pix525防火墻在外網的ip地址是61.144.51.42,內網ip地址是192.168.0.1
                  4. 指定要進行轉換的內部地址(nat)
                  網絡地址翻譯(nat)作用是將內網的私有ip轉換為外網的公有ip.Nat命令總是與 global命令一起使用,這是因為nat命令可以指定一臺主機或一段范圍的主機訪問外網,訪問外網時需要利用global所指定的地址池進行對外訪問。 nat命令配置語法:nat (if_name) nat_id local_ip [netmark]
                  其中(if_name)表示內網接口名 字,例如inside. Nat_id用來標識全局地址池,使它與其相應的global命令相匹配,local_ip表示內網被分配的ip地址。例如0.0.0.0表示內網所有主 機可以對外訪問。[netmark]表示內網ip地址的子網掩碼。
                  例1.Pix525(config)#nat (inside) 1 0 0
                  表示啟用nat,內網的所有主機都可以訪問外網,用0可以代表0.0.0.0
                  例2.Pix525(config)#nat (inside) 1 172.16.5.0 255.255.0.0
                  表示只有172.16.5.0這個網段內的主機可以訪問外網。
                  5. 指定外部地址范圍(global)
                  global命令把內網的ip地址翻譯成外網的ip地址或一段地址范圍。 

                  ?
                  国产一级a做片免费网站,国产一级a做作爱片免费,国产一级电影,国产一级二级三级精品,国产一级二级三级视频
                  <thead id="nfptn"><track id="nfptn"><meter id="nfptn"></meter></track></thead>

                              <font id="nfptn"></font><menuitem id="nfptn"></menuitem>
                              <font id="nfptn"></font><menuitem id="nfptn"></menuitem>
                              <menuitem id="nfptn"></menuitem>
                              <font id="nfptn"></font>